Product SiteDocumentation Site

⁠Глава 33. Диспетчеры файлов

33.1. Диспетчер файлов Dolphin
33.1.1. Домашняя папка
33.1.2. Быстрый доступ к нужным файлам
33.1.3. Копирование и перемещение файлов
33.1.4. Удаление файлов
33.1.5. Открытие файлов
Диспетчеры файлов (или файловые менеджеры) предоставляют интерфейс пользователя для работы с файловой системой и файлами. Диспетчеры файлов позволяют выполнять наиболее частые операции над файлами — создание, открытие/проигрывание/просмотр, редактирование, перемещение, переименование, копирование, удаление, изменение атрибутов и свойств, поиск файлов и назначение прав. Помимо основных функций, многие диспетчеры файлов включают ряд дополнительных возможностей, например, таких как работа с сетью (через FTP, NFS и т.п.), резервное копирование, управление принтерами и прочее.

⁠33.1. Диспетчер файлов Dolphin

Dolphin — это инструмент управления файлами в KDE, удобный и простой в использовании.

⁠33.1.1. Домашняя папка

Домашняя папка
Все ваши файлы и папки хранятся в системе внутри домашней папки (каталог /home/имя_пользователя). Открыть её можно, щёлкнув на значке папки на рабочем столе. Откроется диспетчер файлов Dolphin, позволяющий просматривать содержимое дерева каталогов, удалять, переименовывать и производить прочие операции над файлами и папками.

Примечание

Домашняя папка есть у каждого пользователя системы, и по умолчанию содержащиеся в ней файлы недоступны для других пользователей (даже для чтения).
В домашней папке по умолчанию находятся несколько стандартных папок:
Документы — папка, предназначенная для хранения документов;
Загрузки — в данную папку по умолчанию загружаются файлы из Интернета;
Рабочий стол — содержит файлы, папки и значки, отображающиеся на рабочем столе.
Кроме того, в домашней папке и её подпапках можно создавать другие папки при помощи контекстного меню (Создать → Папку…).

Примечание

Контекстное меню вызывается при помощи щелчка правой кнопкой мыши на объекте. Контекстное меню файла, папки и свободного пространства могут сильно отличаться друг от друга.
Dolphin, как и прочие приложения KDE, содержит руководство пользователя, вызываемое из раздела Справка основного меню или нажатием F1. Ниже описаны лишь некоторые возможности диспетчера файлов. За полным руководством обращайтесь к встроенному руководству пользователя Dolphin.

Примечание

По умолчанию основное меню скрыто. Отобразить его можно из меню Настройки и управление Dolphin → Показать меню.

⁠33.1.2. Быстрый доступ к нужным файлам

Для быстрого доступа к важным и часто используемым папкам, таким как домашняя папка, сетевые папки или корзина, можно воспользоваться панелью Точки входа слева в окне просмотра содержимого папки. Сюда же можно добавить и другие популярные папки. Это можно сделать различными способами. Например:
  • вызвать в свободной области панели Точки входа контекстное меню, выбрать в нём пункт Добавить… и заполнить предложенные поля открывшегося диалога;
  • вызвать контекстное меню на значке папки, которую вы хотите добавить на панель, и выбрать в нём пункт Добавить в «Точки входа».
Панель «Точки входа»
Ориентироваться в сложно организованной системе вложенных папок и быстро перемещаться по ней поможет путь в адресной строке, которая расположена над областью просмотра содержимого папки. Каждая папка в этом пути представлена в виде ссылки. Нажав на ссылку, можно быстро открыть нужную папку.
Адресная строка

⁠33.1.3. Копирование и перемещение файлов

Скопировать или переместить файл или папку можно различными способами:
  • «перетащить» папку или файл из одного открытого окна Dolphin в другое (где открыта целевая папка). Перетаскивание можно осуществлять и в двупанельном режиме. В этом случае не потребуется запускать два экземпляра Dolphin. Нажмите на кнопку Две панели и вы сможете перемещать и копировать файлы и папки, перетаскивая их между панелями.
  • копировать и перемещать папку или файл можно, используя основное стандартное меню Правка (либо контекстное меню):
    • необходимо выделить то, что вы желаете скопировать или переместить, наведя курсор на файл или папку и нажав появившийся знак +;
    • из основного меню Правка или из контекстного меню выберите Копировать (для копирования) или Вырезать (для перемещения);
    • открыть папку, в которую вы хотите скопировать или переместить объект;
    • вызвать в этой папке из основного меню Правка пункт Вставить (или из контекстного меню).

Примечание

Для выбора сразу нескольких файлов или папок можете отмечать их списком, удерживая при этом клавишу Ctrl.

⁠33.1.4. Удаление файлов

По умолчанию фалы и папки удаляются в Корзину. Это позволяет восстановить объект при его ошибочном удалении.
Удалить выделенный объект можно из основного меню Файл (пункт Удалить в корзину). Можно использовать контекстное меню, перетаскивая объект, на значок Корзина в панели Точки входа или удалять объекты клавишей Del.
При ошибочном удалении можно восстановить объект из корзины. Для этого нужно открыть корзину, вызвать на удалённом файле или папке контекстное меню и в нём выбрать пункт Восстановить. Выбор в контекстном меню пункта Удалить может окончательно удалить ненужный файл или папку, без возможности её восстановления.
Для того чтобы безвозвратно удалить всё содержимое корзины, выберите в контекстном меню пункт Очистить корзину.
Для того чтобы не засорять жёсткий диск компьютера ненужными файлами и сразу удалять их, минуя корзину, можно воспользоваться основным меню Файл → Удалить или выбрать соответствующий пункт в контекстном меню.

⁠33.1.5. Открытие файлов

Открыть файл из Dolphin — значит запустить приложение, ассоциированное с этим типом файлов, в нём и откроется файл.

Примечание

Привязки файлов можно настраивать через Параметры KDE5. Выберите в Меню запуска приложений → Параметры системы → Приложения → Приложения по умолчанию.
Например, при щелчке на файл, являющийся изображением (например .jpg файл) откроется программа просмотра изображений Gwenview, в которой откроется изображение. Таким образом, вы можете открывать интересующие вас файлы простым щелчком прямо из диспетчера файлов Dolphin.
Если на компьютере установлено несколько программ для работы с изображениями, то вы можете запустить нужную, выбрав её из контекстного меню (щелчок правой кнопкой мыши по файлу, далее Открыть с помощью…). Вы можете выбрать программу из предлагаемого списка или попробовать открыть файл в произвольном приложении на ваше усмотрение (Открыть с помощью… → В другой программе…).